When you get this message, its because the default setting for VirtualBox sets the OS as the 32 bit version. In this case it was RedHat.



Power down the virtual server, go into settings at set it to 64 bit, save and viola.